Organizations provisioning delays
Incident Report for Coveo Cloud
Resolved
The service is now fully operational. Please report any issues through our Help Portal.
Posted Feb 13, 2018 - 13:17 EST
Monitoring
Thanks for your continued patience. The issue has been fixed and we are actively monitoring this service.
Posted Feb 13, 2018 - 12:59 EST
Identified
We've identified an issue affecting new Organizations creation causing provisioning to be longer than expected.

We’ve identified the root cause and are working on fixing it.

If you need help or to get in touch with us, ​please don’t reply to this email and instead visit our Help Portal
Posted Feb 13, 2018 - 11:39 EST