[All regions] Commerce Advanced dashboard data visibility
Incident Report for Coveo Cloud
Resolved
This incident has been resolved.
Posted Jun 07, 2024 - 04:06 EDT
Identified
Commerce advanced dashboards are showing limited historical data due to a data processing issue. We have identified the issue and are in the process of resolving it.
Posted Jun 06, 2024 - 04:49 EDT