[EU] Coveo Experimentation Hub Issues

Incident Report for Coveo Cloud

Resolved

The service has remained fully operational since the last update. This incident is resolved.
Posted Oct 07, 2025 - 11:26 EDT

Monitoring

Between October 5th 10:00 PM BST and October 7th 1:05 PM BST, a temporary degradation of the Experimentation Hub occurred which prevented dataset imports during that time window. The issue has been fixed and we are closely monitoring the service.

If you need help or to get in touch with us, please visit our Help Portal
Posted Oct 07, 2025 - 10:45 EDT
This incident affected: Europe (Commerce - Coveo Experimentation Hub, Commerce - Coveo Experience Hub).