[All Regions] Login with Google Issues

Incident Report for Coveo Cloud

Resolved

This incident has been resolved. The service has been fully operational since the last update.
Posted Jul 18, 2025 - 16:29 EDT

Monitoring

The issues appear to have been resolved by the third party identity provider. Error rates are back to normal. We are continuing to monitor the service closely.
Posted Jul 18, 2025 - 12:21 EDT

Investigating

We have identified an ongoing issue with the Login with Google feature. Users attempting to login with this third party identity provider are currently seeing abnormally elevated error rates and/or slowness.

If you need help or to get in touch with us, please visit our Help Portal
Posted Jul 18, 2025 - 11:22 EDT
This incident affected: US (Platform - Authentication Service), Europe (Platform - Authentication Service), Australia (Platform - Authentication Service), and Canada (Platform - Authentication Service).