This incident has been resolved. All services have been fully operational since the last update.
Posted May 01, 2025 - 19:30 EDT
Monitoring
A definitive fix has been implemented and we are monitoring the results.
Posted May 01, 2025 - 18:36 EDT
Update
Our initial attempts to mitigate the problem have been successful. We are still working on a permanent solution. Services have been mostly stable for the past thirty minutes, but have continued to experience shorter blips of errors or degraded performance.
Posted May 01, 2025 - 18:11 EDT
Identified
We've identified a potential mitigation action and are taking steps to deploy it. Several other services are also impacted.
Posted May 01, 2025 - 17:35 EDT
Investigating
We've identified an issue causing a partial outage of the Search Service in all regions. Customers are currently experiencing elevated error rates. Our team is investigating and will post regular updates until solved.
If you need help or to get in touch with us, please visit our Help Portal