[Europe] Reduced Performance for Commerce Queries

Incident Report for Coveo Cloud

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 07:44 EDT

Monitoring

The issue has been fixed and we are actively monitoring this service. Thank you for your patience.

If you need help or to get in touch with us, please visit our Help Portal
Posted Sep 18, 2025 - 06:40 EDT

Identified

We’ve identified the root cause and our team is working towards resolution.

If you need help or to get in touch with us, please visit our Help Portal
Posted Sep 18, 2025 - 06:17 EDT

Investigating

We are currently experiencing reduced performance for Commerce queries in the EU region. Our team is investigating and will post regular updates until solved.

If you need help or to get in touch with us, please visit our Help Portal
Posted Sep 18, 2025 - 05:48 EDT
This incident affected: Europe (Commerce).