[All Regions] Support portal Issues

Incident Report for Coveo Cloud

Resolved

The support portal has remained fully operational since the last update. This incident is resolved.
Posted Sep 16, 2026 - 16:29 EDT

Monitoring

The issue seems fixed and we are actively monitoring the support portal. Thank you for your patience.
Posted Sep 16, 2026 - 15:47 EDT

Identified

Due to an ongoing issue with one of our service provider, we are observing intermittent issue preventing some customers of using the support portal in all regions.

Their team is actively working to restore service; you can follow updates on their status page .

If you need immediate assistance and cannot submit a ticket, please contact our support hotline.
Posted Sep 16, 2026 - 08:33 EDT