[All Regions] Search Issues

Incident Report for Coveo Cloud

Resolved

The issue has been fixed for all affected customers. This incident is resolved.

Please report any issues through our Help Portal.
Posted Jul 04, 2025 - 17:34 EDT

Identified

We've detected issues impacting the Search Service in all regions since around 10:30AM EDT for a subset of customers. Our team has applied a fix as of 3:42PM EDT and the service has partially recovered.
Posted Jul 04, 2025 - 16:19 EDT
This incident affected: US (Search - Search Service), Europe (Search - Search Service), Australia (Search - Search Service), and Canada (Search - Search Service).